Администраторы группы

  • Аватар

Модераторы группы

  • Аватар

Использование Vtiger CRM

Открытая группа активность: 1 дн., 13 ч. назад

Обсуждения функциональности, особенностей установки и настройки системы SalesPlatform Vtiger CRM.

не добавляются пользователи после обновления с 6.3 до 6.4 [РЕШЕНО] (записей: 11)

← Форум группы   Все форумы
  • Аватар Правда - 1 г., 6 мес. назад:

    на 6.3 все настроил добавил пользователей
    обновился до 6.4
    добавляю пользователя (без прав администратора) – нажимаю сохранить – белый экран
    нажимаю назад – обновить – новый пользователь есть
    захожу под новыми учетными данными – просит выбрать время – выбираю
    белый экран
    добавляю в настройках пользователя галочку администратор – сохранение проходит штатно (без белых экранов)
    захожу – под этими данными – предлагает выбрать время – выбираю – все работает
    обновление 1 и 2 стоят
    ——————————–
    поднял 6.4 с нуля – обновил
    все работает
    подсовываю базу
    тоже самое – белые экраны
    ПРОБЛЕМА с БАЗОЙ после обновления с 6.3 до 6.4
    как решить?

  • Аватар Правда - 1 г., 6 мес. назад:

    !!!!!

  • Аватар Олег - 1 г., 6 мес. назад:

    Что пишет в error_log апача?
    Права на папку user_privileges установлены?

  • Аватар Роман - 1 г., 6 мес. назад:

    Столкнулся с аналогичной проблемой на тестовой базе. Логи все молчат. Права тут не причем – один и тот же пользователь crm может войти в неё, если у него есть права админа CRM и получает «белый экран» если прав админа нет. 6.4 изначально. Проблема гдето в базе mysql/

  • Аватар Роман - 1 г., 6 мес. назад:

    Похоже нашёл причину – проблема в csrf-magic.

  • Аватар Правда - 1 г., 6 мес. назад:

    как лечить
    и не вылезут еще проблемы со следующими обновлениями

  • Аватар Роман - 1 г., 6 мес. назад:

    Как лечить – не нашёл. База была тестовая, нужное руками перенёс.

  • Аватар Правда - 1 г., 5 мес. назад:

    ???

  • Аватар Правда - 1 г., 5 мес. назад:

    полный игнор

  • Аватар Роман - 1 г., 5 мес. назад:

    Опять случилась эта проблема. Помогло это решение:
    Some time $defaultOrgSharingPermission array generated in sharing_privileges having blank (null) value for respective index. This error stops user to load menu due to which user face blank pages. You just need to go getAllDefaultSharingAction of application_root/include/utils/UserInfoUtil.php and replace
    $copy[$tabid]=$permission; with $copy[$tabid]=empty($permission)?0:$permission;
    Отсюда https://discussions.vtiger.com/index.php?p=/discussion/55840/non-admin-users-get-blank-page-after-login/p1
    Некоторым пользователям пришлось – дать права админа, логин логаут, убрать права админа.

  • Аватар Иван - 10 мес., 3 нед. назад:

    Большое спасибо. Была аналогичная проблема один в один, появилась после миграции с 6.3 до 6.4 И самое печальное что обнаружилась спустя длительное время. Решение найденое Романом решило эту проблему.